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ABSTRAKT 

Hlavním cílem bakalářské práce je popsat a představit hlavní vlastnosti a možnosti vývojo-

vého prostředí CryEngine (verze 5.7.1 LTS), vytvořit dokumentaci v českém jazyce a vy-

vinout komplexní aplikaci, ve které bude představena široká škála funkcí a možností 

CryEngine. Teoretická část práce je zaměřena na popis a vlastnosti daného engine. Prak-

tická část se zaměřuje na použití co největšího množství nástrojů, které CryEngine nabízí. 

První část praktické části práce je zaměřena na tvorbu dokumentace v českém jazyce. Dru-

há část praktické části práce je pak zaměřena na tvorbu aplikace s popsanými kroky tvorby. 

Hlavním výstupem této bakalářské práce je aplikace, která demonstruje širokou škálu 

funkcí tohoto engine a manuál v českém jazyce k engine CryEngine. 

 

Klíčová slova: CryEngine, dokumentace, herní engine 

 

 

 

ABSTRACT 

The main goal of the bachelor thesis is to describe and present the main features and possi-

bilities of the CryEngine development environment (version 5.7.1 LTS), to create docu-

mentation in Czech language and to develop a comprehensive application that will present 

a wide range of CryEngine features and possibilities. The theoretical part of the thesis is 

focused on the description and features of the engine. The practical part focuses on using 

as many tools as possible that CryEngine offers. The first part of the practical part of the 

thesis is focused on creating documentation in Czech language. The second part of the 

practical part of the thesis is focused on creating an application with described steps of 

creation. The main output of this bachelor thesis is an application that demonstrates a wide 

range of features of this engine and a manual in Czech language for the CryEngine engine. 

 

Keywords: CryEngine, documentation, gaming engine 
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ÚVOD 

V dnešní době je herní engine nedílnou součástí zábavního průmyslu. Díky možnostem 

fyzikálního prostředí, rozpohybování 3D modelů, animací a různých grafických efektů je 

možno vytvořit nejen moderní a realisticky vypadající hru, ale třeba také CGI efekty pro 

filmy, seriály či reklamní spoty. 

Vývojáři dnes mají k dispozici velké množství herních engine, ze kterých si lze vybrat.  

A právě díky software a dostatečné hardwarové podpoře je poměrně jednoduché vytvořit 

funkční počítačovou hru či aplikaci. 

Díky neustále se rozvíjejícím počítačovým technologiím lze vytvářet stále realističtější 

grafické prostředí pro aplikace na počítač, mobil, herní konzole či virtuální realitu. Všech-

ny tyto možnosti CryEngine podporuje. 

K počítačové grafice mám poměrně blízko jakožto nadšený hráč počítačových her, kde si 

užívám kromě samotného příběhu i grafické zpracování. Velký přínos vidím také ve zmi-

ňovaných filmech. Ve své době mě nadchly už tehdejší možnosti CGI použité v seriálu 

Putování s dinosaury, kde byli dinosauři, které jsem dříve znal jen z uměleckých obrázků 

odborných knih, zpracováni do pohyblivých 3D modelů.  

V této bakalářské práci se chci věnovat hernímu engine CryEngine právě z důvodu, abych 

si tento engine osvojil a naučil se s ním pracovat, a aby má práce případně pomohla dalším 

studentům či zájemcům o tuto problematiku a usnadnila jim práci s tímto herním engine. 
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I.  TEORETICKÁ ČÁST 

 



UTB ve Zlíně, Fakulta aplikované informatiky 11 

 

1 PŘEDSTAVENÍ A SEZNÁMENÍ S CRYENGINE 

CryEngine je herní engine, jehož vývoj započal v roce 1999 v německém městě Koburk 

vývojářským studiem Crytek. [1] První komerční hra, která byla vytvořena v CryEngine 

pro společnost Ubisoft, se jmenovala Far Cry. V roce 2007 byla vydána novější verze 

CryEngine 2, o dva roky později, v roce 2009, společnost Crytek vydala CryEngine 3. Po 

čtyřleté pauze vyšla v roce 2013 nová verze CryEngine. Tato verze byla natolik odlišná od 

předchozích verzí, že se společnost Crytek rozhodla vydat tuto verzi bez očíslování. Po-

slední verze CryEngine V byla vydána v roce 2016 a doposud nebyla nahrazena verzí no-

vou. Tato verze je i předmětem mé bakalářské práce. [2] 

Mezi známé herní tituly vydané v CryEngine patří Far Cry, Prey, Kingdom Come: Delive-

rance, Climb, Hunt: Showdown, Deceit, série Sniper Ghost Warrior a série Crysis.[3] 
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2 HLAVNÍ VLASTNOSTI A MOŽNOSTI 

CryEngine poskytuje velké množství nástrojů pro práci včetně podpory VR. Poradí si dob-

ře s otevřeným světem ve skvělém grafickém zpracování. 

 Podporuje programovací C++ a C# a skriptovací LUA jazyky. K vytvoření hry není potře-

ba rozsáhlé znalosti programovacích jazyků, spoustu věcí se dá vytvořit pomocí takzva-

ných vizuálních skriptů jako Flowgraph a Schematyc. CryEngine má technickou podporu 

včetně oficiální dokumentace a tutoriálů. 

 CryEngine je poskytován pro nekomerční účely zdarma. Pro komerční účely se platí au-

torské poplatky ve výši 5 % z celkového hrubého výdělku. Od autorských poplatků jsou 

osvobozeny příjmy, které nepřevyšují prvních pět tisíc dolarů za projekt na rok. [4] 

2.1 Vizualizace 

2.1.1 Oblastní světla 

Tento typ světla je explicitně modelován jako plocha se specifickým tvarem, což vede  

k mnohem větší realističnosti než tradiční bodové zdroje světla. Funkce plošných světel 

lépe zobrazuje celkové rozložení světla. 

 

Obrázek 1. Oblastní světla [5] 
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2.1.2 Podpora DirectX 12 

CryEngine také podporuje nízkoúrovňové rozhraní API DirectX 12 od společnosti Micro-

soft. Jedná se o sadu knihoven, které umožňují přímé a efektivní ovládání hardware. Vyu-

žívá se především pro tvorbu počítačových her a multimediálních aplikací. 

2.1.3 Fyzikální vykreslování 

Fyzikální vykreslování slouží k simulaci interakcí mezi světlem a materiály pomocí fyziky 

reálného světa. Simulace chování světla tak jako v reálném světě vede k přirozenějším  

a věrohodnějším výsledkům a zajišťuje, aby materiály vypadaly věrohodně bez ohledu na 

světelné podmínky. Výsledkem je reálnější a působivější svět v projektu. Výhodou použití 

fyzikálně založených modelů je, že k dosažení efektů je zapotřebí méně parametrů, což 

vede k racionálnějšímu pracovnímu postupu tvorby obsahu. 

 

Obrázek 2. Vykreslování [5] 

2.1.4 Dynamická vodní kaustika v reálném čase 

Objem vody a řek podporuje jednotný přístup ke kaustice (obálka světelných paprsků od-

ražených nebo zlomených zakřivenou plochou nebo předmětem). Ty zachycují kaustiku 

1:1 z vodní hladiny, která v kombinaci s vodními vlnami z objektů interagujících s vodou 

vytváří věrohodný efekt. 
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Obrázek 3. Vodní kaustika [5] 

2.1.5 Teselace 

Engine podporuje hardwarově akcelerovanou teselaci na všech objektech, včetně animova-

ných postav. Podporovány jsou tři různé typy teselace: Phong, PN Triangles a Displace-

ment Mapping. První dvě metody teselace jsou určeny k vylepšování objektů, kdy se vez-

me hrubý nízkopolymerový model a pomocí teselace se vytvoří realisticky vypadající ob-

jekt s vyšší věrností. Třetím a nejvýznamnějším typem teselace je Displacement Mapping. 

Tato technika nabízí největší kontrolu nad silou a místem, kde dochází k posunutí pro-

střednictvím výškové mapy. Všechny tyto metody lze v prostředí Sandbox upravovat v 

reálném čase. 

 

Obrázek 4. Teselace [5] 
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2.1.6 3D HDR odlesky objektivu 

Lens Flare je systém, který jednoduchým a intuitivním způsobem vytváří odlesky podobné 

těm, které se používají ve filmovém průmyslu. Pomocí vestavěného editoru Flare Editor je 

možné jediným kliknutím načíst předvolby a přidávat nebo odebírat prvky pro dosažení 

potřebného vzhledu. Editor je navržen tak, aby poskytoval okamžitou vizuální zpětnou 

vazbu. Uživatelé mohou kombinovat více předvoleb. Lens flare lze také použít na jakýkoli 

zdroj světla v úrovni, včetně slunce. 

 

Obrázek 5. HDR odlesky objektivu [5] 

2.1.7 Efektivní antialiasing 

Engine obsahuje i nejnovější iterace vyhlazování, které minimalizují procházení pixelů  

a zajišťují stabilní obraz. CryEngine podporuje časový antialiasing (vyhlazení zubatých 

okrajů), který je dostatečně efektivní pro provoz na všech platformách. Předběžné zpraco-

vání map drsnosti zajišťuje minimalizaci zrcadlového aliasingu, zatímco volitelný filtr 

normálové odchylky v prostoru obrazovky opravuje blikání světel na tenké geometrii. Pro 

případy, kdy je požadována nejvyšší možná věrnost obrazu, je k dispozici dodatečné vzor-

kování. 
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Obrázek 6. Efektivní antialiasing [5] 

2.1.8 Rozmazání pohybu a hloubka ostrosti 

Motion Blur (rozmazání pohybem) lze aplikovat jak na jednotlivé objekty, tak na celou 

scénu. Efekty hloubky ostrosti lze snadno definovat v editoru Sandbox. Efekty jsou im-

plementovány v co nejvyšší kvalitě při nízkých nákladech na výkon na všech podporova-

ných platformách. 

 

Obrázek 7. Rozmazání pohybu [5] 



UTB ve Zlíně, Fakulta aplikované informatiky 17 

 

2.1.9 Místní reflexe v reálném čase 

Odrazy jsou jedním z největších problémů při vykreslování v reálném čase, zejména u en-

ginů s odloženým vykreslováním (výpočet osvětlení se provádí až po výpočtu geometrie). 

CryEngine obsahuje vylepšenou technologii odrazů, takzvaný Screen Space Reflections 

(SSR). SSR odhaduje paprskové HDR odrazy pro místní objekty, což umožňuje, aby jaký-

koli druh povrchu ve scéně efektivně odrážel své blízké okolí v reálném čase. 

 

Obrázek 8. Místní reflexe [5] 

2.1.10 Realistická vegetace 

Vylepšený systém vegetace umožňuje vytvořit velké množství stromů, keřů a rostlin, které 

přesně odráží fyzikální síly ve světě. Tato funkce vnáší život do obvykle statických scén. 

Dokáže simulovat jednotlivá stébla trávy a interagovat s hráčem, umělou inteligencí, dy-

namickými objekty, výbuchy a větrem. 
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Obrázek 9. Vegetace [5] 

2.1.11 Globální osvětlení založené na voxelech 

Jedná se o systém globálního osvětlení založený na voxelech. Rozšiřuje stávající osvětlení 

založené na obrazu (IBL) o rozsáhlou okluzi (vystavení osvětlení) okolí a nepřímý odraz 

světla v reálném čase. Oproti tradičním předpřipraveným řešením nevyžaduje Sparse 

Voxel-Based Global Illumination (SVOGI) žádné dlouhé předběžné výpočty ani ukládání 

na disk. To znamená, že jej lze použít pro obrovská prostředí s otevřeným světem a dyna-

mickou denní dobou, a zároveň zjednodušuje uživatelům návrh úrovní tím, že jim umožňu-

je okamžitě testovat osvětlení v reálném čase. 

2.1.12 Mapy stínů pro jednotlivé objekty 

Mapy stínů umožňují vytvořit vlastní mapy, které lze přiřadit libovolné entitě v úrovni. To 

může vést ke zvýšení kvality stínů díky vyšší hustotě textur stínů ve světě vytvořeného 

levelu a menšímu rozsahu hloubky. Je to užitečné zejména pro cutscény (herní události) 

nebo zahrnutí dodatečné definice stínů u konkrétních objektů. Tato funkce je dostupná 

prostřednictvím speciálního uzlu Flowgraph, který návrhářům poskytuje snadný přístup k 

dynamickým stínům v reálném čase. 
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Obrázek 10. Mapy stínů [5] 

2.1.13 Směrová okluze v prostoru obrazovky 

Jedná se o technologii Screen Space Directional Occlusion (SSDO) ve hrách v reálném 

čase. Nyní SSDO umožňuje zahrnout do výpočtu Ambient Occlusion (realistické dopadání 

světelných paprsků) libovolný počet světel a zohlednit barvu všech světel. SSDO zlepšuje 

přesnost fyzického osvětlení a v konečném důsledku umožňuje vrhat stíny z každého jed-

notlivého zdroje světla v prostředí. 

 

Obrázek 11. Směrová okluze [5] 
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2.1.14 Filmové mapování tónů HDR 

Nejnovější verze mapovače tónů zavádí uživatelem řízenou křivku HDR, která umožňuje 

lepší napodobování chování filmové reprodukce barevných tónů. Nová nastavení umožňu-

je uživatelům přesně nastavit světlé a tmavé hodnoty. Tato funkce umožňuje širší tonální 

rozsah s možností zlepšit definici tmavých, světlých a středních tónů přímým způsobem  

a poskytuje uživateli lepší kontrolu nad expozicí scény. 

2.1.15 Osvětlení na základě obrazu 

Osvětlení na základě obrazu (IBL) přináší lepší osvětlení a vykreslování všech materiálů. 

Stínovací model CryEngine využívá pokročilé hodnoty funkce obousměrného rozložení 

odrazu a normalizaci zrcadlových světel k vykreslení velmi složitých světelných situací. 

Na rozdíl od tradičnějšího nastavení využívá IBL zrcadlovou odrazivost a drsnost materiá-

lů a vrací tak fyzikálně správnější vzhled. Tvrdé zrcadlové odrazy se stávají stejně jedno-

duchými jako jediné vyhledání textury, zatímco rozmazané odrazy lze efektivně aproxi-

movat úpravou úrovně mipmap během vyhledávání. 

 

Obrázek 12. Osvětlení na základě obrazu [5] 
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2.1.16 Systém částicového efektu 

Systém částic je v nejnovější verzi CryEngine navržen tak, že volitelně přenáší správu  

a zpracování částic na grafický procesor. Zároveň umožňuje uživatelům dosáhnout výrazně 

vyšší propustnosti částic pro nákladné efekty, což zvyšuje výkon. 

 

Obrázek 13. Systém částicového efektu [5] 

2.1.17 Objemové stíny mlhy 

V CryEngine je také podporována technika globální mlhy a stínů mraků, která výrazně 

zlepšuje atmosférické podmínky v mlhavém prostředí. Tato funkce je mimořádně výkonná, 

protože vykresluje stíny objektů a mraků do samotné objemové mlhy. 

 

Obrázek 14. Objemové stíny mlhy [5] 
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2.1.18 Mapování paralaxní okluze 

Tato technika, která dodává materiálům větší prostorovou definici, patří mezi další vlast-

nosti CryEngine. Parallax Occlusion Mapping (POM) a Offset Bump Mapping (OBM), 

které jsou podobné stávajícím technikám Tessellation a Displacement, ale jsou mnohem 

méně náročnější na výkon. S pokročilou možností Silhouette Parallax Occlusion Mapping 

je možné vytvořit efekt 3D povrchu, ale také ovlivnit siluetu neboli vykreslenou geometrii 

povrchu, na který je aplikována. [5] 

2.2 Sandbox 

2.2.1 CryEngine Sandbox 

Sandbox umožňuje uživatelům kontrolu nad jejich projekty v reálném čase a nabízí řadu 

efektivních nástrojů. Sandbox lze rozšířit pomocí skriptů a zásuvných modulů tak, aby 

vyhovovaly specifickým potřebám uživatele. 

2.2.2 Editor materiálů 

V tomto editoru je možné nalézt velké množství optimalizovaných shaderů, stejně tak je 

možné přidávání vlastních shaderů pro větší výkon a flexibilitu. 

 

Obrázek 15. Editor materiálů [6] 
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2.2.3 Podpora FBX 

CryEngine podporuje import souborů z jakéhokoli nástroje pro tvorbu digitálního obsahu 

pomocí preferovaného formátu FBX. 

 

Obrázek 16. Podpora FBX [6] 

2.2.4 Intuitivní design úrovní 

CryEngine poskytuje výkonné a intuitivní nástroje pro tvorbu úrovní podle představ uživa-

tele. Prototypy je možné vytvářet pomocí nástroje Designer pro modelování v editoru nebo 

lze vyplnit úroveň procedurálně pomocí nástroje Vegetace. 

 

Obrázek 17. Design úrovní [6] 
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2.2.5 Filmový editor Trackview 

Editor TrackView je vestavěný nástroj pro střih scén, který slouží k vytváření interaktiv-

ních filmových sekvencí s časově závislým ovládáním objektů a událostí. Vytváření filmo-

vých nebo skriptovaných událostí je snadné a umožňuje uživateli sekvencovat objekty, 

animace a zvuky ve scéně. 

 

Obrázek 18. Trackview [6] 

2.2.6 Flowgraph 

Jedná se o jednoduchý, ale výkonný vizuální skriptovací systém CryEngine. Poskytuje 

uživatelům intuitivní rozhraní pro vytváření a ovládání herní logiky a událostí. S přidanými 

vylepšeními pracovního postupu, kterými jsou ladění v reálném čase, body přerušení  

a moduly, se uživatel může soustředit na iteraci a zlepšování hratelnosti. 
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Obrázek 19. Flowgraph [6] 

2.2.7 Integrace látek 

Integrace látkových materiálů CryEngine umožňuje importovat soubory přímo do enginu, 

což poskytuje flexibilitu a možnost ovládat způsob generování materiálů v samotném en-

ginu. [6] 

 

Obrázek 20. Integrace látek [6] 
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2.3 Umělá inteligence a animace 

2.3.1 Technologie postavy 

CryEngine poskytuje škálovatelnější, technicky pokročilejší animační a vykreslovací sys-

témy, které umožňují vytvoření realistické postavy pro hry v reálném čase. Mezi tyto po-

kročilé funkce stínování patří: podpovrchové rozptylování v prostoru obrazovky, realistic-

ké paralaxní mapování duhovky pro zobrazení očí a sjednocené stínovače pro stíny postav 

a vlasů. 

2.3.2 Parametrická skeletová animace 

Díky míchání různých výchozích pohybů na základě uživatelem definovaných parametrů 

poskytuje CryEngine citlivé, interaktivní a detailní ovládání kosterních animací. Postavy se 

pohybují v prostředí a reagují za běhu na změny pohybu, směru nebo rychlosti prolínáním 

animací, čímž vytvářejí realistickou reprezentaci pohybu. 

2.3.3 Geometrická mezipaměť 

Jedná se o podporu ukládání a přehrávání složité simulované geometrie pomocí techniky 

ukládání bodů do mezipaměti, která byla poprvé vyvinuta pro animované filmy. Tento pří-

stup obvykle vede k datům nezvládnutelné velikosti, ale technologie CryEngine ji snižuje 

na 10 % původní velikosti souboru. Interpretovaná "GeomCache" vykresluje stejně efek-

tivně jako statická geometrie, přičemž je možná komprese Lossy-to-Lossless, podpora in-

stancování, streamování a přehrávání ve vyrovnávací paměti. 

2.3.4 Vícevrstvá navigační mřížka 

Vícevrstvá navigační síť (MNM) je vylepšená dynamická navigační datová struktura, kte-

rou umělá inteligence používá k hledání cesty v úrovních. Tento systém je integrován do 

systému CryEngine Sandbox, což znamená, že uživatel definuje oblast, kde má být navi-

gační síť vygenerována, a zbytek řídí MNM. MNM také podporuje dynamické aktualizace 

ve hře v reálném čase, takže když se oblast změní, navigační síť se podle toho bez prodlení 

aktualizuje. 
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2.3.5 Pokročilý systém umělé inteligence 

CryEngine obsahuje výkonnou technologii AI, která zvládá chování postav s modulárními 

smyslovými systémy, jako je sluch a zrak, a podporuje požadavky pohybového systému. 

Umělá inteligence nevyžaduje další middleware a je plně integrována. 

2.3.6 Fyzické přizpůsobení postavy 

Simulační algoritmy byly přizpůsobeny pro efektivní, stabilní a rychlé zpracování postav 

tak, aby nabízely vysoký stupeň realismu při vysokých snímkových frekvencích. Nové 

flexibilní kolize umožní lépe sladit modely a nabídnout realistickou interakci s postavami 

při zachování vysokého výkonu. 

2.3.7 Procedurální deformace pohybu a řešení IK 

Procedurální algoritmy, jako je CCD IK, analytická IK, IK založená na příkladech nebo 

fyzikální simulace, se používají k doplnění předem vytvořených animací, aby se zabránilo 

typickému počítačovému vzhledu. Škálovatelná technika warpingu zachovává styl a obsah 

základního pohybu a zároveň plně zohledňuje omezení daná interaktivním prostředím. [7] 

2.4 Audio 

2.4.1 Editor ovládání zvuku 

CryEngine Sandbox obsahuje Editor ovládání zvuku (ACE). Tento výkonný nástroj umož-

ňuje rychlé flexibilní vytváření a připojování ve stylu drag and drop: událostí, přepínačů, 

stavů a RTPC, jakož i správu nahraných zvukových záznamů. Změny v ACE jsou aktuali-

zovány v reálném čase, zvuk se okamžitě přehrává a není nutné restartovat aplikaci. ACE 

má plně funkční komponentu pro vyhledávání a filtrování, která umožňuje rychle a jedno-

duše najít, zobrazit nebo upravit i obrovské množství zvukových událostí. 



UTB ve Zlíně, Fakulta aplikované informatiky 28 

 

 

Obrázek 21. ACE [8] 

2.4.2 Abstrakce zvuku 

CryEngine také podporuje komunikaci se zvukovým middlewarem, například CRI ADX2, 

FMOD Studio, Miles Sound System nebo Wwise. CryEngine zároveň obsahuje bezplatnou 

alternativu v podobě implementace SDL_mixer. Jmenované middlewarové nástroje jsou 

podporovány standardně a lze je jednoduše aktivovat. 

 

Obrázek 22. Abstrakce zvuku [8] 
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2.4.3 HRTF Spatializace zvuku 

 HRTF poskytuje plné využití 3D zpracování zvuku v reálném čase, které poskytuje přesné 

akustické vlastnosti šíření zvuku v reálném světě. 

2.4.4 Zvukové komponenty 

Pomocí zvukových komponent mohou uživatelé využívat plný výkon zvuku včetně míchá-

ní dozvuků a atmosféry na základě oblasti, bodových FX a manipulace s ovládáním zvuku. 

2.4.5 Zvuková okluze 

V engine je také integrovaná podpora přímé okluze zvuku. V souvislosti s tím je umožněno 

využívat podporovaný zvukový middleware jako například CRI ADX2, FMOD Studio, 

Miles Sound System nebo Wwise. 

 

Obrázek 23. Příklad zvukové okluze [8] 

2.4.6 Dynamický systém odezvy 

Systém dynamické odezvy (DRS) představuje způsob implementace dialogů ve hře. Oddě-

luje vztah dialogu a zpětné vazby od herní logiky. DRS toho dosahuje přidáním abstraktní 

vrstvy mezi něco, co se děje, a probíhající zpětnou vazbu dialogu. DRS lze také použít  

k využití jakéhokoli jiného systému, jako jsou například animace, částice nebo fyzika. [8] 
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Obrázek 24. Dynamický systém odezvy [8] 

2.5 Fyzika 

CryEngine obsahuje kompletní fyzikální řešení, od pevných entit až po objekty a destrukci, 

které umožňují oživit úroveň a hratelnost. Řešení poskytuje podporu pro širokou škálu 

funkcí, včetně libovolných sítí na dynamických objektech a speciálního režimu simulace 

pro kloubové struktury. 

2.5.1 Ohýbání vegetace dotykem 

Funkce Vegetation Touch Bending umožňuje jednotlivým prvkům vegetace fyzickou in-

terakci s objekty, hráči a větrem. 

2.5.2 Vestavěný vztlak a simulace vody 

CryEngine poskytuje přesné výpočty vztlaku pro vodu, vzduch a libovolné tvary objektů. 

Speciální podpora je poskytována pro vlastní objemy vody, řeky a oceánské vlny. Engine 

také podporuje simulaci vody, která se dokáže automaticky přizpůsobit základní geometrii 

plavidla. 

2.5.3 Různé modely destrukcí 

CryEngine poskytuje různé modely realisticky vypadajících destrukcí. To je umožněno 

kombinací předem určených zlomů spojených pomocí tahových spojů a přímou úpravou 

materiálu pomocí dynamického Booleova odečítání. 
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2.5.4 Pokročilá lana 

Nástroj Rope Tool podporuje lana s různými režimy kolize a upevnění. Dokáže auto-

maticky sestavovat lana z opakujících se segmentů.[9] 

2.6 Výkon 

2.6.1 Profilování ve hře 

Profilování ve hře umožňuje okamžité zjištění, kde a kdy se objevily problémy s výkonem. 

Jednotlivé informace se řídí hierarchií, která okamžitě odhalí, o jaké moduly a funkce se 

jedná. Další informace o době trvání a výskytu pomáhají vyhodnotit jejich dopad. 

 

Obrázek 25. Profilování [10] 

2.6.2 Správa vláken řízená daty 

CryEngine se stará o efektivní rozdělení práce mezi softwarová a hardwarová vlákna. Jed-

no centrální místo pro vytváření vláken umožňuje plánovat a sledovat paralelní výpočty za 

běhu. Využití vláken je nezbytné pro aplikace reálného času, aby bylo možno plně využít 

vícejádrový hardware. 

2.6.3 Statoskop 

Výkonný interní diagnostický nástroj Statoscope slouží k získání informací o tom, kde se 

spotřebovává výkon. Přidáním dat do nástroje Statoscope může uživatel zobrazit funkce 

zobrazení statistik na základě jednotlivých snímků v externím nástroji. Buď může data 
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shromažďovat přímo z enginu do nástroje Statoscope, nebo může informace zaznamenat 

do souboru a přečíst je později. Uživatelé navíc mohou překrýt dvě relace snímání na sebe 

a spustit porovnání všech změn provedených mezi oběma relacemi. [10] 

 

Obrázek 26. Statoscope [10] 

2.7 Novinky CryEngine 5.7.1 

Ve verzi CryEngine 5.7.1 byla integrována nová Scaleform 4, která je vylepšením Scale-

form 3. Tato nová verze nabízí lepší výkon vykreslování pro všechny platformy. Je zpětně 

kompatibilní s jazykem ActionScript 2.0 a zároveň podporuje jazyk ActionScript 3.0, který 

zase umožňuje používat Adobe Animate. Scaleform 3 je ovšem stále k dispozici pro případ 

chyb či nefunkčnosti Scaleform 4 v projektu. 

Scaleform Schematyc byl přidán pro účely emulace nezbytných funkcí, které poskytuje 

Flow Graph pro systém uživatelského rozhraní. Prvky uživatelského rozhraní jsou k dispo-

zici jako komponenty, zatímco funkce a události odpovídající těmto prvkům lze definovat 

v souboru Element XML. Podporuje Scaleform 3 a 4. 

Rovněž byl aktualizován modul GamePlatform, který byl dodáván se systémem CryEngine 

5.6. Aktualizované funkce zahrnují podporu různých platforem, jako jsou Steam, PlaySta-

tion a Xbox. Nově obsahuje volitelný zásuvný modul, který poskytuje vizuální skriptovací 

uzly pro Flow Graph a Schematyc. Discord Rich Presence SDK byl aktualizován na Dis-

cord Game SDK. 
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Kód enginu a CMake byly aktualizovány tak, aby podporovaly Visual Studio verzí 2017, 

2019 a 2022, zatímco podpora Visual Studio 2015 byla vyřazena. Spolu s touto aktualizací 

byla přidána podpora implementace standardu C++17, zatímco sada Windows SDK byla 

aktualizována na verzi 10.0.20348.0. [11] 
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3 POROVNÁNÍ CRYENGINE 

3.1 Porovnání s Unity 

Unity je software používaný především k vývoji videoher pro počítačové a mobilní plat-

formy. Používá se také v oblasti rozšířené a virtuální reality. Unity bylo vyvinuto společ-

ností Unity Technologies v roce 2005. Jedná se o multiplatformní herní engine. Původně 

byl navržen pouze pro operační systém OS X, ale nyní jej lze používat na různých platfor-

mách, jako jsou Windows, Mac atd. Unity je zdarma a je přístupný všem. Snadno se pou-

žívá, takže jej využívá většina herních vývojářů pro tvorbu her a aplikací. Je napsán v ja-

zycích C++ a C#. Používá se k vytváření 2D a 3D her. 

3.1.1 Výhody a nevýhody 

Výhody Unity: 

• Jedná se o multiplatformní engine pro vývoj her, což znamená, že hry lze používat 

na více platformách. 

• Je nejlepší pro nezávislé vývojáře her, protože jeho osobní licence je zdarma. 

• K dispozici je velké množství zásuvných modulů, které rozšiřují jeho možnosti. 

• Má vlastní obchod, ze kterého lze stahovat předpřipravené herní produkty. 

Nevýhody Unity: 

• Vykreslování v Unity je ve srovnání s CryEngine pomalejší. 

• Import šablon z jiných platforem není povolen, takže je třeba vše vytvořit od začát-

ku. 

Výhody CryEngine: 

• Snadno se používá a vyžaduje pouze základní znalosti programování. 

• Podporuje funkce VR. 

• Umožňuje integraci s mnoha softwary, jako je Blender, Maya atd. 

• Je vhodný pro hry AAA. 

Nevýhody CryEngine: 

• K plynulému běhu softwaru je zapotřebí výkonný procesor. 

Vyžaduje grafickou kartu s nejnovějším ovladačem. [12] 
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Tabulka 1 Unity vs CryEngine [12] 

Unity CryEngine 

Společnost Unity poskytuje osobní 

licenci zdarma a profesionální licen-

ci za 1800 dolarů ročně, tj. 150 dola-

rů měsíčně 

Je k dispozici za 9,90 dolarů za mě-

síční předplatné 

Podíl na trhu činí 11 % Podíl na trhu činí přibližně 5 % 

Požívá programovací jazyky C# a 

C++ 

Požívá programovací jazyky C# a 

C++ a LUA 

Nemá kód s otevřeným zdrojovým 

kódem 

Má kód s otevřeným zdrojovým 

kódem, který je k dispozici na serve-

ru GitHub 

Má velkou komunitu, která čítá při-

bližně 210 tisíc členů 

Ve srovnání s Unity má menší ko-

munitu 

K dispozici pro Windows i Mac K dispozici pouze pro operační sys-

témy Windows 

3.2 Porovnání s UnrealEngine 5 

Unreal Engine je počítačový software vytvořený za účelem vývoje her, jedná se tedy  

o herní engine. Zásluhu na vývoji tohoto softwaru má společnost Epic Games a poprvé byl 

uveden na trh v roce 1998. Jeho autorem je Tim Sweeney. Je schopen vytvářet 2D a 3D 

hry. Je k dispozici pro různé operační systémy, jako je Windows, MacOS atd. Snadno se 

používá a je schopen vytvářet komplexní hry. 

3.2.1 Výhody a nevýhody 

Výhody Unreal Engine: 

• Má snadné rozhraní, s nímž lze snadno začít vyvíjet hry. 

• Obsahuje implementovaný uzlový editor, který umožňuje vývoj hry bez psaní kó-

du. 

• Dokáže poskytovat velmi kvalitní grafické výstupy v reálném čase Má lepší tech-

nologii vykreslování, která je poměrně rychlejší než ostatní herní enginy. 
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• Dodává se s předpřipravenými herními úrovněmi, které vývojářům her poskytují 

základní kostru aplikace. 

Nevýhody Unreal Engine: 

• Účtuje si 5% licenční poplatek, jakmile uživatelem publikovaná hra přesáhne výdě-

lek 1 milion dolarů. 

• Poskytuje méně zásuvných modulů než Unity. 

• Potřebuje výkonný procesor spolu s vyhrazenou grafickou kartou a pamětí. 

Výhody CryEngine:  

• V současné době je CryEngine nejpoužívanějším nástrojem pro tvorbu počítačo-

vých her. 

• Snadno se používá a vyžaduje pouze základní znalosti programování. 

• Podporuje funkce VR. 

• Umožňuje integraci s mnoha softwary, jako je Blender, Maya atd. 

• Je vhodný pro hry AAA. 

Nevýhody CryEngine: 

• K plynulému běhu softwaru je zapotřebí výkonný procesor. 

• Vyžaduje grafickou kartu s nejnovějším ovladačem. [13] 

Tabulka 2 Unreal Engine vs CryEngine [13] 

Unreal Engine CryEngine 

Používání je zdarma, ale při překro-

čení výdělku na hře 1 milion dolarů 

je účtován 5% licenční poplatek 

Je k dispozici za 9,90 dolarů za mě-

síční předplatné 

Podíl na trhu činí 23 % Podíl na trhu činí přibližně 5 % 

Požívá programovací jazyky C++ a 

Blueprint 

Požívá programovací jazyky C# a 

C++ a LUA 

2. místo v herním průmyslu. 7. místo v herním průmyslu. 

K dispozici pro Windows i Mac K dispozici pouze pro operační sys-

témy Windows 
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II.  PRAKTICKÁ ČÁST 
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4 TVOBRA DOKUMENTACE V ČESKÉM JAZYCE 

Dokumentace vznikla jako součást bakalářské práce. Tato dokumentace byla vytvořena za 

pomocí stránek oficiální dokumentace CryEngine od společnosti CRYTEK, které sloužily 

jako vzor. [14] Z oficiální dokumentace byly vybrány ty nejpodstatnější nástroje, instalace 

CryEngine 5.7.1 LTS pomocí CryEngine Launcher verze 2.1.3 a tyto informace byly dopl-

něny o poznatky na základě zkušenosti práce s enginem. Dokumentace odkazuje na inter-

netové stránky, ze kterých bylo čerpáno, včetně odkazů na jednotlivé kapitoly pro podrob-

nější informace k dané problematice. 

4.1 Nástroje CryEngine uvedené v manuálu 

CryEngine obsahuje velké množství nástrojů pro práci a editaci levelu v engine. 

V manuálu jsou popsány následující nástroje: 

• Create Object, 

• Flow Graph, 

• Lens Flare Editor, 

• Material Editor, 

• Terrain Editor, 

• Vegetation Editor. 

Tyto nástroje budou použity a demonstrovány v praktické části této bakalářské práce.  

 

Obrázek 27. Titulní strana dokumentace 
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5 TVORBA APLIKACE 

K tvorbě aplikace a jejího levelu v engine je použit CryEngine GameSDK Sample Pro-

ject, který je k dispozici ke stažení v databázi prostředků. [15] Tento ukázkový projekt je 

zvolen z důvodu, že oproti standardním šablonám, které jsou k dispozici ihned po instalaci 

engine, nabízí velké množství objektů, materiálů, modelů postav a vegetace. Ukázkový 

projekt je určen pro začínající uživatele CryEngine tak, aby tvorba prvních projektů byla 

uživatelsky co nejjednodušší. Nabízí také rozumně vypadající HUD a základní hlavní me-

nu, které lze použít a editovat podle potřeb uživatele CryEngine. 

5.1 Návrh aplikace 

Aplikace, která je součástí této bakalářské práce, bude vytvořena jako FPS (First person 

shooter) s použitím co největšího množství efektů a nástrojů tak, aby byla demonstrována 

praktická práce s těmito nástroji k dosažení požadovaného autorova výsledku. 

Vzhledem k tomu, že aplikace je definována jako FPS, bude pohled hráče z pohledu první 

osoby. Cílem hry bude dosažení kontrolních bodů a interakce s těmito body, které budou 

definovány jako mise hry. Hra tedy nabídne hráči dva možné způsoby splnění dané mise, 

buď přímým postupem a eliminací nepřátelských postav, anebo opatrnějším postupem po 

mapě, při kterém si bude muset hráč dát pozor na detekování nepřítelem. Hra má celkem 

čtyři mise. 

5.2 Tvorba levelu 

Tato kapitola byla tvořena s pomocí knihy CryEngine1 3 Cookbook [16], kniha je věnová-

na CryEngine 3, tudíž některé informace nebyly aktuální, a tak byly dodatečné informace 

čerpány z online tutoriálů [17] [18]. 

Po stažení prostředku CryEngine GameSDK Sample Project je potřeba vytvořit projekt. 

Projekt lze vytvořit v menu Launcheru v záložce Asset library. Po vyhledání tohoto pro-

středku v knihovně je potřeba kliknout na ikonu  a poté z kontextové nabídky vybrat 

možnost Generate project from asset. Po zobrazení okna Crate project je potřeba vypl-

nit název projektu a cestu v adresáři, kde bude projekt uložen. 

Po načtení Sandbox Editoru v okně Asset browser ve složce GameSDK/levels byly od-

straněny ukázkové levely (složka _testmaps, multiplayer/airfield a singleplay-

er/woodland). 
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Nový level byl vytvořen pomocí nástroje File → New → Level… Po zobrazení okna Cre-

ate level bylo vybráno umístění ve složce levels a název levelu byl nastaven na level. Po 

zobrazení nového okna New Level nastaveny parametry Heightmap resolution na 

512x512 a Texture dimensions na 1024x1024. Poté dojde k vygenerování nového levelu 

s rovnou plochou bez textur, kterou je potřeba upravit. V levém okně Level Settings byl 

nastaven parametr Detail Layers View na hodnotu 5 pro nastavení vzdálenosti vykreslo-

vání textur jednotlivých vrstev. 

 

Obrázek 28. Nový level 

5.3 Tvorba terénu 

Vygenerované ploše byla přidělena základní textura pomocí nástroje Tools → Terrain 

Editor → Paint. Ve vlastnostech vrstvy Grass byly změněny následující parametry: 

• Texture – Vybrána textura GameSDK/textures/terrain/detail/grass, 

• Material – Vybrán materiál GameSDK/materials/terrain/grass_1. 

 

Vrstva Grass po spuštění v herním módu působí vybledlým dojmem bez barvy, to lze 

upravit v parametru materiál kliknutím na ikonu  

a následně provést nastavení pro materiál s následujícími parametry: 
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• Difuse color - "r": 12, "g": 147, "b": 66, "a": 255, 

• Emissive color - "r": 33, "g": 148, "b": 81, "a": 255. 

Následně bylo provedeno vyvýšení terénu pomocí nástroje Tools → Terrain Editor → 

Raise/Lower s nastavením parametrů Radius (outside) na 26, Hardness na 1 a Height na 

9 tak, aby okraje vygenerované plochy tvořily přirozené ohraničení herní plochy a celkové 

nerovnosti terénu tak, aby výsledný terén tvořil různotvárné prostředí. Při nastavení para-

metru Height na zápornou hodnotu dojde ke snižování výšky terénu. 

V nástroji Tools → Terrain Editor → Paint byla vytvořena další vrstva s názvem Rock, 

která je použita pro nastavení textury ohraničení mapy horami s následujícími parametry: 

• Texture – Vybrána textura GameSDK/textures/terrain/detail/ textu-

res/terrain/detail/rock_3d, 

• Material – Vybrán materiál GameSDK/materials/terrain/ mate-

rials/terrain/rock_4. 

 

Stejně jako u vrstvy Grass bylo provedeno u vrstvy Rock nastavení pro materiál 

s následujícími parametry: 

• Difuse color - "r": 99, "g": 99, "b": 99, "a": 255, 

• Emissive color - "r": 72, "g": 72, "b": 72, "a": 255. 

Pomocí nástrojů Tools → Terrain Editor → Sculpt → Flatten a Tools → Terrain Edi-

tor → Sculpt → Smooth bylo provedeno vyrovnání a zahlazení terénu k výsledné podobě 

jako na obrázku 29. 

 

Obrázek 29. Pohled na upravený level z hráčovy perspektivy 
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5.4 Vkládání entit prostředí 

Aby herní mapa nepůsobila prázdným dojmem, je potřeba do levelu vložit různé entity 

prostředí. Do levelu budou vloženy budovy, vegetace a entity objektů jako třeba kameny. 

Pro tyto účely bude použito nástrojů Create Object → Brush pro vkládání jednotlivých 

entit a Tools → Vegetation Editor, který je vhodný zejména pro vkládání více entit na-

jednou na definované ploše rádiusem. 

5.4.1 Vkládání vegetace pomocí Vegetation Editor 

V nástroji Tools → Vegetation Editor byly vytvořeny 3 skupiny vegetace pomocí tlačítka 

Add Group. Vytvořené skupiny nesou názvy Grass, Bushes a Trees. 

Vytvořená skupina Grass obsahuje následující objekty weed_v_var a small_grass_a, které 

budou tvořit základní pokrytí terénu travnatým porostem s defaultním nastavením parame-

trů vyjma parametrů, které byly nastaveny následujícím způsobem: 

• Random Rotation – True, 

• Use Terrain Color – True, 

• Air Resistance – 0,7, 

• Density – 6, 

• Elevation Min – 0. 

 

Tato skupina byla nanesena pomocí nástroje Paint s nastaveným rádiusem 60. 

Skupina Bushes obsahuje následující objekty green_fern_bush_b a bux_hedge_ball_big, 

které budou tvořit pokrytí terénu větším porostem s defaultním nastavením parametrů vy-

jma parametrů, které byly nastaveny následujícím způsobem: 

• Random Rotation – True, 

• Air Resistance – 0,7, 

• Density – 45, 

• Elevation Min – 16. 

Tato skupina byla nanesena pomocí nástroje Paint s nastaveným rádiusem 60. 
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Skupina Trees obsahuje následující objekty river_tree_d, river_tree_c a river_tree_b, 

které budou tvořit pokrytí terénu stromy s defaultním nastavením parametrů vyjma para-

metrů, které byly nastaveny následujícím způsobem: 

• Random Rotation – True, 

• Air Resistance – 1,  

• Density – 26, 

• Elevation Min – 0. 

Tato skupina byla nanesena pomocí nástroje Paint s nastaveným rádiusem 60. 

Po nanesení těchto tří skupin na terén bylo provedeno doladění pokrytí terénu jednotlivými 

skupinami pomocí nástroje Paint s různým nastavením rádiusu a pomocí nástroje Erase 

byly objekty vegetace odstraněny z povrchů, kam nepatří. 

 

Obrázek 30. Přidána vegetace do levelu 

5.4.2 Vkládání objektů pro terén pomocí nástroje Brush 

Dotvoření přírodního ohraničení mapy levelu bylo vytvořeno pomocí nástroje Create Ob-

ject → Brush. Tímto nástrojem bylo vloženo 42 entit pro skalní útvary, jedná se o entity: 

• objects/natural/rocks/cliff_rocks/cliff_rock_b_big, 

• objects/natural/rocks/cliff_rocks/cliff_rock_a_med, 

• objects/natural/rocks/beach_rocks/beach_rock_med_b_con. 

Pro práci s jednotlivými entitami byly dále použity nástroje pro posun – Move, rotaci – 

Rotate, velikost – Scale, kopírování – Edit → Copy a vložení – Edit → Paste. 

 Pomocí zmíněných nástrojů byly entity rozmístěny po okrajích levelu tak, aby byly vytvo-

řeny hranice pomocí skalních útvarů. Jakmile bylo vytvořeno ohraničení, tak byl level pro-
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zkoumán z pohledu první osoby hráče tak, aby byly odhaleny případné nedokonalosti při 

vkládání a polohování objektů. 

 Pomocí Terrain Editor → Sculpt → Smooth byly dodělány finální úpravy terénu pro 

skály tak, aby terén nepřesahoval nad entitami a případně tyto entity nepřekrýval. 

 Veškeré skalní útvary byly vloženy do nově vytvořené vrstvy Rocks, která se nachází 

v hlavním okně Level Explorer. U každé vrstvy je potřeba kliknutím pravým tlačítkem 

myši v kontextovém menu v položce Layer → More vybrat možnost Auto-Load pro zob-

razení této vrstvy ve finálním .exe souboru. Všem objektům v položce Properties byla 

zakázána volba Cast Shadow Maps pro lepší viditelnost textur a menší nároky na jejich 

zpracování. 

 

Obrázek 31. Pohled na skalní ohraničení levelu 

5.4.3 Tvorba vodopádu 

Pro samotou texturu vodopádu byl do levelu projektu vložen nástrojem Create Object → 

Brush objekt s názvem objects/natural/rocks/cliff_rocks/cliff_rock_a_med. Tento objekt 

byl poté pomocí nástroje Edit → Copy zkopírován a nástrojem Move posunut před pů-

vodní objekt. Zkopírovanému objektu byla pro efekt padající vody přiřazena nová textura s 

názvem objects/natural/water/waterfall/waterfall. 

Efekty padající vody byly vytvořeny pomocí objektu Particle entity – emitor částic, 

v nástroji Tool → Database View. Po kliknutí na záložku Particles je zapotřebí vytvořit 

novou částici pomocí tlačítka Add New Item. 

 Do databáze byly přidány nové částice s názvem Top a Down. Objekt Top představuje 

emitor částic pro vrchní část vodopádu a Down představuje spodní část vodopádu. 
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 Každý emitor má vlastní nastavení pro dosažení požadovaného výsledku tak, jak je zobra-

zeno v nastavení v obrázcích 32 a 33. 

 

Obrázek 32. Nastavení emitoru pro objekt Down 

 

 

Obrázek 33. Nastavení emitoru pro objekt Top 

 

Nově vytvořené objekty lze přetáhnutím myši vložit do levelu na požadované místo a po-

mocí nástrojů Move, Rotate a Scale nastavit polohu, natočení a velikost emitovaných čás-

tic do požadované podoby vodopádu. Veškeré objekty pro vodopád byly vloženy do nově 

vytvořené vrstvy Water, která se nachází v hlavním okně Level Explorer. U vrstvy je po-
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třeba po kliknutí pravým tlačítkem myši v kontextovém menu v položce Layer → More 

vybrat možnost Auto-Load pro zobrazení této vrstvy ve finálním .exe souboru. 

 

Obrázek 34. Výsledná podoba vodopádu 

5.4.4 Tvorba řeky 

Řeka byla vytvořena pomocí nástroje Create Object → Misc → River. Nejprve byla vy-

tvořena křivka, která definuje tvar řeky. Každé kliknutí myší při tvorbě řeky vytváří spoj – 

čím více spojů, tím složitější tok řeky může být vytvořen. Tuto křivku lze pomocí nástroje 

Move posunout v ose Z níž pod terén, to je vhodné zejména pro tvorbu koryta řeky. 

 Pomocí funkce Align Height Map, která se nachází v Properties → Road, se terén za-

rovná v ose Z ke křivce řeky a tím se vytvoří koryto. Příkaz Properties → Road → Erase 

Vegetation zase odstraní vegetaci v korytě řeky. Řeka byla vytvořena pomocí defaultního 

nastavení s tím, že parametr řeky Width byl nastaven na hodnotu 44 a materiál pro řeku 

byl nastaven materials/water/watervolumes/water_forest_b. Entita řeky poté byla pře-

sunuta do vrstvy Water společně s dalšími dvěma emitory částic (Down) pro efekt dopadu 

vody z vodopádu do řeky. 

Pro texturu koryta řeky byla vytvořena další vrstva v Tools → Terrain Editor → Paint 

s názvem River s následujícími parametry: 

• Texture – Vybrána textura GameSDK/textures/terrain/river_pepples_no_water, 

• Material – Vybrán materiál GameSDK/materials/terrain/river_bank_terrain_a. 

Tato vrstva byla poté nanesena pomocí nástroje Paint na koryto řeky. 
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Obrázek 35. Výsledná podoba řeky 

5.4.5 Tvorba cesty 

Nejdříve bylo třeba vytvořit most přes řeku vložením entity mostu, k tomu bylo použito 

Create Object → Brush a model bridges/wooden_bridge/sb_wooden_bridge_main. 

 K vytvoření mostu by bylo možné použít jen jednu entitu a pomocí Scale upravit délku 

mostu, tato možnost ovšem nepřipadala v úvahu, protože by most působil nepřirozeným 

dojmem. Z tohoto důvodu byly použity čtyři entity daného modelu, které byly srovnány do 

stejné výšky a poté spojeny. Dále bylo úpravou terénu Tools → Terrain Editor vytvořeno 

napojení terénu na most. Pro všechny entity mostu byla vypnuta v Properties vlastnost 

Cast Shadow Maps. 

Veškeré objekty pro most byly vloženy do nově vytvořené vrstvy Road, která se nachází 

v hlavním okně Level Explorer. U vrstvy je potřeba po kliknutí pravým tlačítkem myši 

v kontextovém menu v položce Layer → More vybrat možnost Auto-Load pro zobrazení 

této vrstvy ve finálním .exe souboru. 

Cesta se tvoří podobně jako objekt řeka, ale s nástrojem Create Object → Misc → Road. 

Cestu tvoří dohromady tři entity cesty. První entita je cesta, která vede z hráčovy startovní 

lokace k mostu. Druhá cesta vede z mostu k lokaci, kde se bude nacházet cíl úkolu. Třetí 

cesta je vytvořena kvůli lepšímu přechodu z travnatého terénu k cestě první. Pro každou 

cestu byla nejprve vytvořena křivka, která definuje její tvar; každé kliknutí myší při tvorbě 

cesty vytváří spoj – čím více spojů, tím složitější tvar cesty může být vytvořen.  

 Pomocí funkce Align Height Map, která se nachází v Properties → Road, se terén za-

rovná v ose Z ke křivce cesty a tím dojde k plynulému přechodu z terénu na entitu cesty. 
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Properties → Road → Erase Vegetation zase odstraní vegetaci v místě cesty. Cesty byly 

vytvořeny pomocí defaultního nastavení s tím, že parametr cesty Width byl nastaven na 

hodnotu 4 a materiál pro cesty byl nastaven materials/roads/forest_trail. Entity všech tří 

cest byly poté přesunuty do vrstvy Road. Poté byly prostřednictvím nástrojů editor terénu 

(Tools → Terrain Editor) a editor vegetace (Tools → Vegetation Editor) provedeny 

finální úpravy v okolí cesty, které byly následně implementovány automatickými funkcemi 

Align Height Map a Erase Vegetation. Výsledná cesta je zobrazena na obrázku 36, pro 

lepší viditelnost cesty byly skryty modely vegetace stromů. 

 

Obrázek 36. Výsledná podoba cesty 

5.4.6 Vložení objektů prostředí 

K dotvoření celkového prostředí levelu byly použity nástroje Create Object → Brush  

a Create Object → Legacy Entities. Nástrojem Brush byla vytvořena malá vesnice, 

v této vesnici se bude nacházet první cíl mise. Vesnice byla vytvořena z modelů: 

• objects/architecture/fences/wooden_fence/wooden_fence, 

• objects/architecture/buildings/fishing_houses/wood_table, 

• objects/architecture/buildings/fishing_houses/wood_chair, 

• objects/architecture/buildings/outdoor_toilet/outdoor_toilet, 

• objects/architecture/buildings/observatory_tower_a/observatory_tower_a, 

• objects/architecture/buildings/loghouse/loghouse_pile, 

• objects/architecture/buildings/forest_cabin/forest_cabin, 

• objects/architecture/buildings/fishing_houses/fishing_house_shelter, 

• objects/architecture/buildings/fishing_houses/fishing_house_a, 

• objects/architecture/buildings/fishing_houses/barrel, 

• objects/props/misc/camp_fires/camp_fire_set/camp_fire_a. 
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K objektu ohniště – objects/props/misc/camp_fires/camp_fire_set/camp_fire_a byl při-

dán emitor částic pro efekt ohně – Particle Effect, s názvem Campfire, který byl vytvořen 

v Tool → Database View→ Add New Item. 

Objekty na mapě byly napolohovány nástroji Move, Rotate a Scale a terén pod objekty 

byl zarovnán nástrojem Tools → Terrain Editor → Flatten. 

 

Obrázek 37. Výsledná podoba vesnice 

Dále byl vytvořen hangár s budovami, ve kterém se bude nacházet poslední cíl mise. Tato 

oblast byla rovněž vytvořena nástrojem Brush. Zde byly použity tyto modely: 

• objects/architecture/buildings/hangar/hangar, 

• objects/architecture/buildings/storage_hall/storage_hall_destroyed, 

• objects/architecture/buildings/storage_hall/storage_hall. 

I zde bylo použito nástrojů Move, Rotate, Scale a Tools → Terrain Editor → Flatten 

pro konečné úpravy. 

Do modelu hangáru byla vložena okna, která lze rozbít pro lepší efekt – model ob-

jects/props/misc/breakable_glass/window2. Tyto modely byly vloženy přímo z Asset 

Browseru přetažením myši a byla upravena jejich velikost a umístění tak, aby pasovala do 

modelu hangáru.  

Pro celkový podkres prostředí byly do levelu doplněny další modely pro kameny a na star-

tovní lokaci hráče vložen model poškozeného vrtulníku společně s emitory částic pro efek-

ty kouře – Particle Effect, s názvem Smoke, a oheň – Particle Effect, s názvem Fire, které 

byly vytvořeny v Tools → Database View→ Add New Item. 
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Veškeré modely byly vloženy do nově vytvořené vrstvy Misc, která se nachází v hlavním 

okně Level Explorer. U vrstvy je potřeba po kliknutí pravým tlačítkem myši 

v kontextovém menu v položce Layer → More vybrat možnost Auto-Load pro zobrazení 

této vrstvy ve finálním .exe souboru. 

 

Obrázek 38. Výsledná podoba objektu cíle 

Dále byly do levelu vloženy entity pomocí nástroje Create Object → Legacy Entities. 

Tyto entity obsahují různé efekty a spouštěče. Do levelu byly vloženy následující entity 

pro dokreslení prostředí levelu: 

• Turtles – želvy jsou umístěny poblíž vodopádu. Entita byla vložena s defaultním 

nastavením s tím, že byla upravena hodnota parametru Count na hodnotu 3 a pa-

rametry Pickable When Alive a Pickable When Dead vypnuty. 

• Frogs – žáby jsou umístěny na druhé straně koryta řeky u vodopádu. Entita byla 

vložena s defaultním nastavením s tím, že byla upravena hodnota parametru Count 

na parametry 4 a hodnoty Pickable When Alive a Pickable When Dead vypnuty. 

• Fish – ryby jsou umístěny v korytě řeky. Dohromady byly vloženy čtyři entity typu 

Fish. Entity byly vloženy s defaultním nastavením s tím, že byla upravena hodnota 

parametru Count na hodnotu 20. 

• Chickens – kohouti jsou umístěni ve vesnici prvního cíle. Entita byla vložena 

s defaultním nastavením s tím, že byla upravena hodnota parametru Count na hod-

notu 3 a parametry Pickable When Alive a Pickable When Dead vypnuty. 
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• Bugs – hmyz je umístěn v lese a podél cesty. Dohromady bylo vloženo dvacet jed-

na entit typu Bugs. Entity byly vloženy s defaultním nastavením s tím, že byla 

upravena hodnota parametru Behaviour na hodnotu 1 a parametr Activate zapnut. 

• Birds – ptáci jsou umístěni podél první cesty před mostem. Dohromady byly vlo-

ženy dvě entity typu Birds. Entity byly vloženy s defaultním nastavením. 

• Light – osvětlení je umístěno ve vesnici prvního cíle pro přípravu na užití nástroje 

Lens Flare. Tato entita byla vložena s defaultním nastavením s tím, že byly uprave-

ny hodnoty parametrů Attenaution Buld Size na hodnotu 5 a Radius nastaven na 

5. 

• HealthPack – lékárničky jsou umístěny ve vesnici prvního cíle a ve startovní loka-

ci pro doplnění životů hráčovy postavy. Tyto entity byly vloženy s defaultním na-

stavením s tím, že byly upraveny hodnoty parametrů Health na hodnotu 10000  

a Respawn Time nastaven na 60. 

• AmmoCrate – kufr s municí je umístěn ve vesnici prvního cíle a ve startovní loka-

ci pro doplnění munice do zbraní hráčovy postavy. Tato entita byla vložena 

s defaultním nastavením s tím, že byly upraveny hodnoty parametrů Number Of 

Recharges na hodnotu 0 a Use Message nastaven na „Refill all ammo“. 

• PlayerSpawnPoint – hráčova počáteční pozice je ve startovní lokaci. Tato entita 

byla vložena s defaultním nastavením. 

• MH60_Blackhawk – pozice pro vrtulník Blackhawk se nachází v poslední cílové 

lokaci. Tato entita byla vložena s defaultním nastavením. 

Veškeré modely byly vloženy do nově vytvořené vrstvy Game, která se nachází v hlavním 

okně Level Explorer. U vrstvy je potřeba po kliknutí pravým tlačítkem myši 

v kontextovém menu v položce Layer → More vybrat možnost Auto-Load pro zobrazení 

této vrstvy ve finálním .exe souboru. 
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Obrázek 39. Výsledná startovní lokace 

5.4.7 Nastavení prostředí levelu a počasí 

Pro přidání efektu mraků je od verze CryEngine 5.4 nutné pro uchování tohoto nastavení 

přidat do souboru gamesdk.cryproject (tento soubor lze otevřít v textovém editoru, napří-

klad notepad) pod console_variables příkaz "r_VolumetricClouds": "1 [ ]", viz obrá-

zek 40. 

 

Obrázek 40. Vložení příkazu 

Pro vytvořený level je zapotřebí vytvořit nastavení pro prostředí levelu, aby bylo možné 

upravit a nastavit hodnoty pro proměnné prostředí tak, aby šlo toto nastavení uložit a bylo 

načteno vždy při otevření projektu nebo .exe souboru. Nové nastavení pro prostředí lze 

vytvořit v okně Level Settings v záložce Environment Presents kliknutím na ikonu slož-

ky. V nově vytvořeném okně Select Environment se po kliknutí pravým tlačítkem myši 

otevře kontextové menu a výběrem New Asset → Environment se vytvoří nový soubor 

pro prostředí, které bylo pojmenováno enviroment_settings. Po kliknutí na ikonu editace 
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záložky Environment Presets se otevře okno pro editaci dané entity, které nabízí velké 

množství parametrů pro změnu prostředí levelu. Tato část byla provedena editací parame-

trů tak, aby výsledný efekt napodobil deštivé počasí, které bude odpovídat následnému 

zavedení efektů pro déšť. Hlavně byly změněny parametry pro denní dobu, pro vítr, mraky 

a osvětlení levelu slunečními paprsky, viz obrázek 41. Toto nastavení je nutné uložit po-

mocí volby Save. Výsledný stav oblohy a slunečního svitu je vidět na obrázku 42. 

 

Obrázek 41. Nastavení prostředí 

 

Obrázek 42. Výsledný pohled na oblohu 

Efekt padajícího deště byl vytvořen nástrojem Tools → Particle Edior. Zde byla vybrána 

particle entita rain s nastavením parametru Amount na 0,6 ve funkci Spawn:Density 

v efektu grafu pro tuto entitu. Obě entity byly vloženy do vrstvy Main v okně Level explo-

rer. 
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Obrázek 43. Výsledný efekt deště 

5.5 Přidání audio efektů nástrojem ACE 

Pro audio bylo v tomto projektu místo defaultního ACE middleware – SDL Mixer použito 

staženého middleware – Wwise, protože nabízí větší množství zvukových efektů, které 

budou v projektu použity a které defaultní middleware postrádá. Wwise byl stažen 

z databáze prostředků. [19] Po stažení je potřeba zkopírovat složku CryEngine Wwise 

Project do složky projektu gamesdk\audio. 

Pro nastavení Wwise jako výchozího ACE middleware je potřeba přidat do souboru game-

sdk.cryproject (tento soubor lze otevřít v textovém editoru, například notepad) pod conso-

le_variables příkaz "s_ImplName": "CryAudioImplWwise", viz obrázek 44. 

Dále je důlezité v Sandbox Editoru otevřít nástroj Tools → Audio Controls Editor. Po 

otevření okna Audio Controls Editor je nutné změnit nastavení pro Project Path na au-

dio/CryEngine Wwise Project, toho lze dosáhnout kliknutím na ikonu  → Edit → Pre-

ferences. 
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Obrázek 44. Editace gamesdk.cryproject 

Po nastavení výchozího ACE middleware je možno vložit více zvukových efektů pro vy-

tvořený level. 

Do levelu byly vloženy celkem čtyři entity pro audio efekty nástrojem Create Object → 

Audio → Audio Trigger Spot s následujícím umístěním a nastavením: 

• AudioWaterfall – entita umístěna v objektu vodopádu s defaultním nastavením 

s tím, že parametr Play Trigger Name byl nastaven na 

Play_l_global_sfx_waterfall_large_loop. 

• AudioRain – entita umístěna ve startovní lokaci. Tato entita poskytuje efekt pro 

celou mapu levelu. Entita byla vytvořena s defaultním nastavením s tím, že parame-

tr Play Trigger Name byl nastaven na Play_l_global_amb_rain_exterior. 

• AudioFire – entita umístěna ve startovní lokaci v modelu poškozeného vrtulníku 

BlackHawk s defaultním nastavením. Parametr Play Trigger Name byl nastaven 

na Play_p_pfx_fire_blackhawk_mh60. 

• AudioCampfire – entita umístěna v první cílové lokaci vesnice v modelu ohniště 

s defaultním nastavením. Parametr Play Trigger Name byl nastaven na 

Play_p_pfx_fire_campfire. 

Veškeré entity pro audio efekty byly vloženy do nově vytvořené vrstvy AudioFX, která 

se nachází v hlavním okně Level Explorer. U vrstvy je potřeba po kliknutí pravým tla-

čítkem myši v kontextovém menu v položce Layer → More vybrat možnost Auto-

Load pro zobrazení této vrstvy ve finálním .exe souboru. 
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5.6 Tvorba cílů hry pomocí Flow graph 

Tato kapitola byla tvořena s pomocí knih Mastering CryEngine [2], CryEngine1 Game 

Programming with C++, C#, and Lua [20] a CryEngine Game Development Blueprints 

[21]. Tyto knihy jsou věnovány CryEngine 3, tudíž některé informace nebyly aktuální,  

a tak byly dodatečné informace čerpány z online tutoriálů [18]. 

Pro vytvoření cílů hry je nejprve zapotřebí vytvořit soubor objectives.xml v umístění 

\gamesdk\levels\singleplayer\level\leveldata\objectives.xml a do něj zapsat úkoly misí. 

 

Obrázek 45. Vytvořené úkoly v xml souboru 

V nástroji Tools → Database View v záložce Game Tokens byly vytvořeny proměnné 

pro jednotlivé stavy misí. 

 

Obrázek 46. Vytvořené proměnné pro stavy úkolů 
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Dále bylo vytvořeno nástrojem Create Object → Legacy Entities osm entit 

Následujícího názvu, typu a účelu: 

• AreaTrigger-1 – AreaTrigger – spouštěcí entita pro první misi, 

• AreaTrigger-2 – AreaTrigger – spouštěcí entita pro třetí misi, 

• FillFuel – Switch – tlačítko pro splnění cíle druhé mise (zde byl změněn výchozí 

model tlačítka switch), 

• Fuel – Switch – tlačítko pro splnění cíle třetí mise,  

• Mission1 – MissionObjective – entita reprezentující první misi, 

• Mission2 – MissionObjective – entita reprezentující druhou misi, 

• Mission3 – MissionObjective – entita reprezentující třetí misi, 

• Mission4 – MissionObjective – entita reprezentující čtvrtou misi. 

Dále byly vytvořeny nástrojem Create Object → Area → Box dvě entity následujícího 

názvu, typu a účelu: 

• AreaBox-1 – AreaBox – Ohraničení pro spouštěcí entitu první mise, 

• AreaBox-2 – AreaBox – Ohraničení pro spouštěcí entitu třetí mise. 

Na závěr byla vytvořena nástrojem Create Object → Empty Entity entita s názvem Mis-

sions, která obsahuje Flow graph s logikou implementace pro systém dosažení cílů hry. 

Veškeré entity byly vloženy do nově vytvořené vrstvy Objectives, která se nachází 

v hlavním okně Level Explorer. U vrstvy je potřeba po kliknutí pravým tlačítkem myši 

v kontextovém menu v položce Layer → More vybrat možnost Auto-Load pro zobrazení 

této vrstvy ve finálním .exe souboru. 

Celý systém cílů hry je realizován následujícím způsobem. Hráči se po načtení levelu zob-

razí text, který jej bude informovat o krátkém příběhu. Na HUD se hráči zobrazí první cíl 

mise, a to najít palivo do vrtulníku. Palivo se nachází v cisterně ve vesnici v pozici prvního 

cíle hry, který je definován spouštěčem AreaTrigger-1. Po nalezení cisterny se první úkol 

dokončí a zobrazí se druhý úkol. Druhým úkolem je, aby hráč načerpal palivo pro vrtulník. 

Tento cíl hráč splní dvojím stisknutím klávesy F u cisterny – entita FillFuel, jakmile se 

zobrazí zpráva „Take fuel“, poté se cíl dokončí a v HUD se zobrazí hráči třetí cíl hry. Tře-

tím cílem hry je palivo doplnit do vrtulníku. Tento úkol lze splnit u hangáru dvojím stisk-

nutím klávesy F, po zobrazení zprávy „Fill fuel“ na tlačítku entity Fuel, která se nachází 

na vrtulníku. Poté se zobrazí čtvrtá mise, která hráče informuje, že nyní může odletět 
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s vrtulníkem. Po nástupu do vrtulníku je mise splněna, příběh končí a aplikace je ukonče-

na. Hráč si může aktuální misi zobrazit stisknutím klávesy O. V cílech hry jsou ošetřeny 

situace, kdy hráč chce použít vrtulník, aniž by doplnil palivo. Zobrazí se upozornění, které 

informuje hráče o tom, že vrtulník potřebuje palivo a není schopen s vrtulníkem odletět – 

úkol čtyři. Stejně tak je ošetřena situace, kdy hráč chce do vrtulníku natankovat palivo, ale 

palivo nenabral. Zobrazí se upozornění, že nemá palivo a není mu umožněna interakce 

s tlačítkem úkol tři. Úkol dva lze splnit pouze tehdy, pokud se hráč dostane do vymezené-

ho prostoru entity AreaTrigger-1. Úkol jedna se spouští hned při načtení levelu. 

Následující obrázky znázorňují implementaci logiky úkolů pomocí nástroje Tools → Flow 

Graph. 

 

Obrázek 47. Inicializace proměnných při načtení levelu 
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Obrázek 48. Implementace prvního úkolu 

 

Obrázek 49. Implementace druhého úkolu  
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Obrázek 50. Implementace třetího úkolu 

 

Obrázek 51. Implementace čtvrtého úkolu 
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Obrázek 52. Implementace zobrazení aktuálního úkolu  

 

Obrázek 53. Implementace upozornění 

5.7 Úprava hlavního menu a obtížnosti 

Pomocí nástroje Tools → Flow Graph bylo rovněž upraveno hlavní menu, které ukázkový 

projekt poskytuje. Z menu byla odstraněna tlačítka pro multiplayer, připojení k serveru  

a jiné. Tlačítko Single player bylo nahrazeno tlačítkem Play. Byly rovněž odstraněny ob-

tížnosti vyšší než normal. Výběr obtížnosti nyní nabízí obtížnost Easy a Normal. 

V adresáři gamesdk byla vytvořena složka Difficulty, ve které byly vytvořeny dva soubo-

ry easy.cfg a normal.cfg, které odpovídají zvolené obtížnosti. Hlavní rozdíl ve zvolené 

obtížnosti je ten, že v obtížnosti Easy se hráči po pěti sekundách doplní automaticky životy 



UTB ve Zlíně, Fakulta aplikované informatiky 62 

 

na plný počet. U obtížnosti Normal se tomu tak neděje a hráč je tedy odkázán pouze na 

lékárničku, kterou může najít na mapě ve vesnici a ve startovní lokaci. 

5.8 Použití nástroje Lens Flare na objekt Slunce 

Pro vytvoření efektu odlesku objektivu ze slunečního svitu je nejprve důležité vložit do 

mapy levelu entitu typu Light nástrojem Create Object → Legacy Entities. Na umístění 

této entity na mapě nezáleží, po aplikaci efektu Lens Flare tato entita již nebude vydávat 

světlo. V Properties entity Light, která byla dříve vytvořena ve vesnici prvního cíle, byl 

zapnut parametr Flare Enable. Dále byl použit nástroj Tools → Lens Flare Editor. Po 

zobrazení okna Lens Flare Editoru, byla tlačítkem Load Library přidána knihovna 

sample_flares. Pro efekt odlesku byl vybrán efekt generic.generic_sun_flare. Po označení 

entity Light v Sandbox Editoru byl v okně Lens Flare Editoru aplikován efekt tlačítkem 

Assign Item to Selected Objects. Pro aplikaci efektu na Slunce byl nastaven v Properties 

entity Light parametr Diffuse Multiplier na hodnotu 10 a byl zapnut parametr Attach to 

Sun. 

 

Obrázek 54. Výsledný efekt Lens Flare 

5.9 Vložení a nastavení nepřátelských postav 

Do levelu bylo vloženo nástrojem Create Object → Legacy Entities celkem 47 objektů 

typu Human. Tyto objekty byly vloženy s defaultním nastavením s tím, že menším skupi-

nám objektů byl změněn parametr Model tak, aby nepřátelé ve hře nevypadali stejně. Po 

testování herního prostředí a reakce nepřátel byly změněny parametry u všech nepřátel tak, 

aby úhel zorného pole, vzdálenost detekce hráče a reakce nepřátel odpovídaly prostředí  

a náročnosti hry s ohledem na to, aby hra byla dostatečně náročná, ale přitom nebyla příliš 

obtížná. Tímto způsobem byly změněny následující parametry: 
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• Auto Disable – Zapnuto, 

• Go Back To Start On Idle – Zapnuto, 

• Interest → Angle – 270, 

• Min Interest Level – 0, 

• FOV Primary – 180, 

• FOV Secondary – 270, 

• Sightrange – 35. 

Dále bylo do levelu vloženo nástrojem Create Object → AI → AI Path celkem 16 objek-

tů typu AIPath. Tyto objekty definují cestu, po které se budou nepřátelé pohybovat. Každý 

nepřítel, kterému je přiřazena cesta, má vlastní Flow Graph s implementovanou logikou 

pro sledování této cesty, viz. obrázek 55. 

 

Obrázek 55. Implementace logiky pro sledování cesty 

Nakonec byla do levelu nástrojem Create Object → Empty Entity vložena prázdná, pro 

hráče neviditelná entita, která obsahuje Flow Graph logiku pro odstranění objektu Human 

ze hry po jeho eliminaci, viz. obrázek 56. 

Veškeré nové entity byly vloženy do nově vytvořené vrstvy Enemies, která se nachází 

v hlavním okně Level Explorer. U vrstvy je potřeba po kliknutí pravým tlačítkem myši 

v kontextovém menu v položce Layer → More vybrat možnost Auto-Load pro zobrazení 

této vrstvy ve finálním .exe souboru. 
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Obrázek 56. Odstranění modelu nepřítele 

5.10 Finální úpravy 

V této fázi byla hra poskytnuta dobrovolníkům k otestování hratelnosti a celkového dojmu 

z vytvořeného levelu. Na základě testování byly od dobrovolníků poskytnuty tyto podněty 

k vylepšení: 

• Vylepšit celkové osvětlení levelu. 

• Příkré břehy řeky – upravit břehy řeky tak, aby se hráč po pádu do řeky mohl dostat 

na břeh. 

• Absence zobrazení kláves pro ovládání hry. 

• Přidat navigaci k cílům mise. 

Do mapy levelu bylo přidáno celkem 38 entit typu Light pro celkové osvětlení mapy. 

Každá entita má umístění a parametry nastavené tak, aby byla mapa lépe osvětlena, zvláště 

pod stromy. Tyto entity byly vloženy do nově vytvořené vrstvy MapLights, která se nachá-

zí v hlavním okně Level Explorer. U vrstvy je potřeba po kliknutí pravým tlačítkem myši 

v kontextovém menu v položce Layer → More vybrat možnost Auto-Load pro zobrazení 

této vrstvy ve finálním .exe souboru. Zároveň byly upraveny parametry prostředí levelu 

pro lepší světelný efekt. 

Břehy řeky byly upraveny pomocí Terrain Editoru dle požadavků a zároveň bylo přidáno 

více trávy a keřů do levelu pro lepší vizuální efekt. 
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Do hlavního menu a do menu při pozastavení hry bylo tlačítko Show Controls, které načte 

nově vytvořené menu v nástroji Flow Graph. Toto menu zobrazuje přiřazení kláves 

k možným akcím ve hře. 

Na herním HUD byla aktivována funkce navigace k aktuálnímu cíli mise, kterou reprezen-

tuje červená tečka v levém dolním rohu obrazovky. Logika navigace byla implementována 

v již existujícím Flow Graph grafu s názvem Missions pro každý úkol mise zvlášť, viz 

obrázek 57. Tato část byla problémová. Například po vyvolání menu pozastavením hry  

a návratu do hry došlo ke ztrátě údajů o pozici hráče a pozici úkolu a již nedošlo 

k opětovnému načtení údajů. Tento problém je vyřešen na obrázku 58. 

 

Obrázek 57. Doplnění funkcionality navigace k cíli první mise 

 

Obrázek 58. Opětovné načtení údajů aktuální mise po pozastavení hry 
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Na závěr pro odstranění in-game debug informací na obrazovace je potřeba přidat do sou-

boru gamesdk.cryproject (tento soubor lze otevřít v textovém editoru, například notepad) 

pod console_variables příkaz "r_DisplayInfo": "0", viz obrázek 59. 

 

Obrázek 59. Deaktivace in-game debug informací 

5.11 Uživatelský pohled na hru 

Hlavní menu hry zobrazené na obrázku 60 obsahuje tlačítko Play, které po kliknutí nabízí 

volbu obtížnosti a následné spuštění levelu. Tlačítko Game Settings nastavuje citlivost 

myši. Tlačítko Graphic Settings umožňuje nastavení celé obrazovky, rozlišení a kvality 

obrazu. Sound Settings nastavuje hlasitost hry a tlačítko Show Controls zobrazuje přiřa-

zení kláves k interakcím ve hře. Celostránkové obrázky z této hry jsou umístěny v příloze 

č. II. 

 

Obrázek 60. Hlavní menu 



UTB ve Zlíně, Fakulta aplikované informatiky 67 

 

ZÁVĚR 

Cílem této bakalářské práce bylo popsat a představit hlavní vlastnosti a možnosti vývojo-

vého prostředí CryEngine (verze 5.7.1 LTS), vytvořit dokumentaci v českém jazyce a vy-

vinout komplexní aplikaci, ve které bude představena široká škála funkcí a možností 

CryEngine.  

V teoretické části bakalářské práce jsou popsány hlavní vlastnosti a možnosti herního en-

gine CryEngine. Teoretická část dále pojednává o přidaných novinkách ve verzi CryEngine 

5.7.1 LTS. Na závěr teoretické části je CryEngine porovnáván s konkurenčním softwarem 

Unity a Unreal Engine. 

Praktická část bakalářské práce je věnována tvorbě dokumentace v českém jazyce a poté se 

zaměřuje na návrh a tvorbu aplikace od základní myšlenky až po samotnou tvorbu, jejíž 

proces je v práci podrobně popsán. 

Tvorbu aplikace komplikovaly drobné problémy, zejména pak občasné a nečekané pády 

herního engine při tvorbě mapy levelu. Z tohoto důvodu byl postup při tvorbě aplikace 

průběžně ukládán a celý projekt byl zálohován. Záloha projektu byla využita při jednom 

z pádů engine, kdy nešel projekt nadále otevřít a pracovat na něm. 

Výstupem této bakalářské práce je tedy manuál v českém jazyce a aplikace. Výsledná apli-

kace je FPS hra, která demonstruje grafické možnosti tohoto herního engine při použití co 

největšího množství nástrojů, které CryEngine nabízí. 

Součástí této bakalářské práce je USB flash disk. Na disku se nachází CryEngine projekt, 

ve kterém aplikace vznikala, dokumentace v českém jazyce a samotná aplikace. Projekt lze 

otevřít v CryEngine otevřením souboru gamesdk.cryproject, který se nachází ve složce 

Project. Aplikaci lze spustit souborem SWIGame.exe, který se nachází ve složce SWIGa-

me\bin\win_x64. Na disku je rovněž instalátor Visual C++ Redistributable, který je po-

třebný pro spuštění aplikace. 

Projekt i aplikace měly být původně distribuovány pomocí instalátoru na USB flash disku. 

Instalátor byl tvořen v Microsoft Visual Studiu pomocí rozšíření Microsoft Visual Studio 

Installer Projects. Po nainstalování aplikace pomocí instalátoru se aplikace sice  

otevřela, ale již nedošlo k načtení levelu hry. Proto bylo od distribuce pomocí instalátoru 

upuštěno.  
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 computer-generated imagery 

Application Programming Interface 

PN  Point-Normal 
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SVOGI 
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OBM 

MNM 

CCD IK 

ACE 

RTCP 

HRTF 

 Screen Space Reflections 

High Dynamic Range 

Sparse voxel octree global illumination 

Image-based lighting 

Screen Space Directional Occlusion 

Parallax Occlusion Mapping 

Offset Bump Mapping 

Multi-Layer Navigation Mesh 

Cyclic Coordonate Descent Inverse Kynematic 

Audio Controls Editor 

Real-Time Transport Control Protocol 

head-related transfer function 

DRS 

SDK 

LTS 

HUD 

FPS 

 Dynamic Response Systém 

Software development kit 

Long term support 

Heads-up display 

First person shooter 
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SEZNAM PŘÍLOH 

 

Příloha P I: USB flash disk obsahuje: 

- Složka Project obsahující celý CryEngine projekt – spustitelný soubor 

 gamesdk.cryproject 

- Složka Visual C++ Redistributable for Visual Studio 2015-2022 obsahující 

instalátor VC_redist.x64.exe 

- Soubor ve formátu PDF/A r_marecek_dokumentace_cryengine.pdf 

- Složka SWIGame obsahující výslednou aplikaci – spustitelný soubor 

 SWIGame.exe v adresáři SWIGame\bin\win_x64 

 

Příloha P II: Snímky ze hry: 
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